Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Agent long time to get the chunk. Sending keepalive progress to avoid timeout...
#1
Hi guys!

  • 0.12.0 commit 2be8530 branch master
  • Python agent v0.6.1
  • Hashcat v6.2.3
  • #HL# -a 3 -m 11300 -w 4 -O -1 wgvxzip37838IJGSDUEB -2 37838 -3 wgvxzipIJGSDUEB sr?2?1?1?1?1?1?1?1?3
  • Chunk size: 600
  • Status timer: 10
  • Benchmark Type: Speed Test
I have 2 agents:

  1. The first one is on Linux and with two nvidia (3060 and 3070).
  2. The second one is on Windows 10 and 6 x RX470.
I have configured the agents for one task.
The first agent at the end of working out the chunk, gets the next chank in 10 seconds.
The second agent writes messages for a very long time:

Sending keepalive progress to avoid timeout...

[Image: 1628795160486.png]

But after 5-6 minutes, it takes a chunk and starts working. As a result, the second agent on Win is idle most of the time. Below are the screenshots that show this. Tell me, what could be the reason for this behavior and how to fix it?

Debug output from the client:
Code:
Sending keepalive progress to avoid timeout...
{'action': 'sendProgress', 'token': '******', 'chunkId': 118, 'keyspaceProgress': 4417554188, 'relativeProgress': 0, 'speed': 0, 'state': 2, 'cracks': []}
https://hashcat.sitename.ru:443 "POST /api/server.php HTTP/1.1" 200 None
b'{"action":"sendProgress","response":"SUCCESS","cracked":0,"skipped":0,"zaps":[]}'

Below you can see the inactivity of about 6 minutes for the second agent:

[Image: 1628795431354.png]

[Image: 1628795793309.png]
Reply
#2
The keepalive thing shows that Hashcat takes some time to start up on your Windows agent. This most likely is tied to the Mode and the fact that it's Windows, if you run a task with -m 11300 manually on the agent with the same Hashcat version, you should expect also a 5-6 min delay until Hashcat actually starts to work on a task.
In this time Hashcat normally compiles/initializes/starts up the GPUs, if there are multiple GPUs, it has to do it for each of them. Worst case this can take quite some time.

If you don't find a way to speed up Hashcat in this startup, I recommend setting the chunk size to something higher than 10 minutes (600 seconds), so the startup time does not make that much of the total time anymore (e.g. set it to 3600s or even higher).
Reply
#3
(08-14-2021, 08:13 PM)s3in!c Wrote: The keepalive thing shows that Hashcat takes some time to start up on your Windows agent. This most likely is tied to the Mode and the fact that it's Windows, if you run a task with -m 11300 manually on the agent with the same Hashcat version, you should expect also a 5-6 min delay until Hashcat actually starts to work on a task.
In this time Hashcat normally compiles/initializes/starts up the GPUs, if there are multiple GPUs, it has to do it for each of them. Worst case this can take quite some time.

If you don't find a way to speed up Hashcat in this startup, I recommend setting the chunk size to something higher than 10 minutes (600 seconds), so the startup time does not make that much of the total time anymore (e.g. set it to 3600s or even higher).

I found the problem.
My video cards are connected via PCIe GEN 2.0 via a reiser. This greatly slows down the initialization of cards on my motherboard. When I insert the cards directly, and put them in the BIOS GEN 3.0, everything works quickly.

Regarding the execution time of the chunk (3600), I did so. Thanks for the help.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)