Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
no hashcat download
follow on from thread

Ubuntu server-x86_64-16.10 > client Ubuntu 16.04 LTS

I tried extracting the python client in Client/home directory, import a new agent, & run all commands from there without "sudo". I tried giving the cracker binaries the download link with confirmed internet access (http"s" is OK, right ?). I tried an example from this forum where the cracker binary is suggested to be copied to eg: /home/user or maybe /var/www/hashtopolis/files & also */import. I also tried the files/import function to ensure it got to the right directory, each time confirming & changing cracker binary download url (eg; http://<server-ip-address>/home/user. Where applicable I set the binaries to "not locked" & allowed the client access to "locked or secure" files. Rebooted.
Still no hashcat download, extract & run.
Still having issues at this point, so did a new install, & allowed all privileges on hashtopolis server config as in an older video, hit the "go" button & confirmed settings were saved. I confirmed the suggested changes from server-prerequisites wiki were made & saved correctly. I set the /etc/apache2/apache2.conf <Directory /var/www> line to "AllowOverride All" I notice that there are some .htaccess files in directories that might be critical, that are still set to "Deny:all" on the 2nd line.
Am I supposed to change these manually ? & in which directories ? syntax as in apache2.conf ?
I guessed the allowoverride was supposed to do that, but the apache2 docs I found online seem to suggest that .htaccess overrides apache2.conf settings. Confused.
Not using yubikey at all.

latest debug output below :
cd ~/hashtopolis-agent-python

@ubuntu:~/hashtopolis-agent-python$ sudo wget http://192.168.1.**/agents.php?download=1
[sudo] password for user:
--2019-07-06 15:52:43-- http://192.168.1.**/agents.php?download=1
Connecting to 192.168.1.**:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [application/force-download]
Saving to: 'agents.php?download=1’

agents.php?download=1 [ <=> ] 24.81K --.-KB/s in 0s

2019-07-06 15:52:43 (81.1 MB/s) - 'agents.php?download=1’ saved [25410]

@ubuntu:~/hashtopolis-agent-python$ sudo mv agent*
@ubuntu:~/hashtopolis-agent-python$ sudo chmod +x

@ubuntu:~/hashtopolis-agent-python$ python3 ./ --voucher ***** --url http://192.168.1.**/api/server.php
Starting client 's3-python-0.5.0'...
Successfully registered!
Collecting agent data...
Login successful!
Hashtopolis Server version: 0.11.0 ()
Client is up-to-date!
Downloading: [==================================================]
No task available!
No task available!
No task available!
....stopped here.

Created task/s 1 & 2, assigned the agent, confirmed agent & server config settings :
@ubuntu:~/hashtopolis-agent-python-master$ python3 ./ --debug --voucher ***** --url http://192.168.1.**/api/server.php
Starting client 's3-python-0.5.0'...
Collecting agent data...
{'uid': '****-**-**-**-**-****', 'action': 'updateInformation', 'os': 0, 'devices': ['Intel® Core™2 Quad CPU Q9650 @ 3.00GHz', 'NVIDIA Corporation GK107 [GeForce GT 640] (rev a1)'], 'token': 'AABBCCDD12'}
Starting new HTTP connection (1): 192.168.1.**
"POST /api/server.php HTTP/1.1" 200 51
{'action': 'login', 'clientSignature': 's3-python-0.5.0', 'token': 'AABBCCDD12'}
"POST /api/server.php HTTP/1.1" 200 106
b'{"action":"login","response":"SUCCESS","multicastEnabled":false,"timeout":30,"server-version":"0.11.0 ()"}'
Login successful!
Hashtopolis Server version: 0.11.0 ()
{'token': 'AABBCCDD12', 'action': 'checkClientVersion', 'version': '0.5.0', 'type': 'python'}
"POST /api/server.php HTTP/1.1" 200 67
Client is up-to-date!
Entering loop...
{'action': 'getFileStatus', 'token': 'AABBCCDD12'}
"POST /api/server.php HTTP/1.1" 200 62
{'action': 'getTask', 'token': 'AABBCCDD12'}
"POST /api/server.php HTTP/1.1" 200 354
b'{"action":"getTask","response":"SUCCESS","taskId":2,"attackcmd":"-a3 #HL# ?l?l?l?l?s?l?l?l?l?d?d?d hash-test123","cmdpars":" --hash-type=0 ","hashlistId":1,"bench":30,"statustimer":5,"files":["hash-test123"],"crackerId":"2","benchType":"speed","hashlistAlias":"#HL#","keyspace":"0","usePrince":false,"enforcePipe":false,"slowHash":false,"useBrain":false}'
Got task with id: 2
{'token': 'AABBCCDD12', 'action': 'downloadBinary', 'binaryVersionId': '2', 'type': 'cracker'}
"POST /api/server.php HTTP/1.1" 200 153
Starting new HTTPS connection (1):

### STUCK HERE over 5 mins multiple times ###

used this :
"action":"getTask","response":"SUCCESS","taskId":2,"attackcmd":"-a3 #HL# ?l?l?l?l?s?l?l?l?l?d?d?d hash-test123"

& "taskId":1 without "hash-test123" included in command line.
I tried 2 ways, both times confirming the actual hashlist was part of the Task further down the page > "files":["hash-test123".
Also with the md5 hashlist added to command line from files/other as shown above.
Incorrect I think, but gettiing desperate.
Is this a hardware issue ? eg; only works on a proper server MoBo etc ?
Running server from an lga775 socket MoBo.

Thanks for support so far.
Any help appreciated.
Most likely your hashcat link is not accessible from your agents. Did you test that you can do
wget ''
on the agents?

Also note that your executable name is still set wrong, this only needs to contain the basename (hashcat in that case).
Hardware cannot be a compatibility issue, as long as you can run apache2 and MySQL on it.
Didn't know about "wget" test.
The "executable name" is understood, but tried all possible options to see what works.


Forum Jump:

Users browsing this thread: 1 Guest(s)